Algoritmia Unidad II

 renezeuz10000

Examen Teórico

1. ¿Qué se entiende por Algoritmo?

2. Son tipos de Algoritmos

3. Datos que se usan en algoritmos

4. Como se le llama donde es asignado un dato y que puede cambiar su valor

5. El Identificador Area y la variable radio son pertenecientes a una Expresión Area(radio)=(pi*radio^2)/2

6. Ayuda a los programadores a desarrollar algoritmos en un lenguaje cotidiano antes de escribirlo en un lenguaje de programación

7. Los algoritmos de tipo lineal o secuencial se ejecutan con una programación estructurada

8. Definen una logica estructurada en un algoritmo

9. Es verdadero o falso el siguiente algoritmo:

CALIF1,NOTA2,SUMAR,SUMAPRODUCTO son números precisos
escribir “Introduzca las notas”
leer NOTA1,NOTA2
calcular SUMA = NOTA1 + CALIF2
calcular PRODUCTO = NOTA1 * NOTA2
escribir “La suma de las dos notas es:” SUMA
escribir “El producto de las dos notas es :”PRODUCTO
Finprograma

10. Del siguiente algoritmo que hace falta:

Escribir “Introduzca un número “
leer NUMERO
SI NUMERO>0 ENTONCES escribir “El número introducido es positivo” SI NUMERO<0 ENTONCES escribir “El número introducido es negativo” escribir “El número es cero” FINSI
FINSI
Finprograma

11. Del siguiente programa que realiza:

programa suma_divisibles
variables natural : divisor, suma, contador, número
inicio programa
divisor leer ‘Introduce el divisor: ’
suma 0
contador 0
para número desde 1 hasta 1000 hacer
si divisor divide a número entonces
suma suma + número
contador contador + 1 fin si si contador = 10 entonces
interrumpir fin si
fin para
escribir ‘La suma es’, suma
fin programa

12. La estructuras si entoces fin si pertenecen a

13. Desde...hasta

14. ¿Cuál es el siguiente paso después de plantear el algoritmo y el pseudocódigo?

15. La Algoritmia ayuda a resolver problemas en cualquier lenguaje de programacion


© 2015 Expertics.